package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\b)`)
var str = `VII
CMXL
XII
XVII
IV
MMMIII
MXI
MXIV
MM
MC
MM
I
VI
MX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}