import Foundation
let pattern = #"(\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
VII
CMXL
XII
XVII
IV
MMMIII
MXI
MXIV
MM
MC
MM
I
VI
MX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)