import re
regex = re.compile(r"https?:\/\/github\.com\/(?<owner>[a-z\d](?:[a-z\d]|-(?=[a-z\d])){0,38})\/(?<repo>[a-z\d._-]{1,100})\/(issues|pull)\/(?<issueNumber>\d+)(?<issueComment>#issuecomment-(?<issueCommentNumber>\d+))?", flags=re.IGNORECASE)
test_str = ("https://github.com/spacehub-mn/spacehub/issues/new/choose\n"
"https://github.com/spacehub-mn/spacehub/issues/311")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")