re = /https?:\/\/github\.com\/(?<owner>[a-z\d](?:[a-z\d]|-(?=[a-z\d])){0,38})\/(?<repo>[a-z\d._-]{1,100})\/(issues|pull)\/(?<issueNumber>\d+)(?<issueComment>#issuecomment-(?<issueCommentNumber>\d+))?/i
str = 'https://github.com/spacehub-mn/spacehub/issues/new/choose
https://github.com/spacehub-mn/spacehub/issues/311'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end