#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w\.-]+@[\w\.-]+\.\w+"
Local $sString = "asd@domain.com" & @CRLF & _
"asd@domain" & @CRLF & _
"asd.asd@domain.com" & @CRLF & _
"asd@my-domain.com" & @CRLF & _
"asd@domain-my.co.uk" & @CRLF & _
"asd@domain.co.uk" & @CRLF & _
"asd@domain.co.uk.gov.mil." & @CRLF & _
"asd@example.local-local email" & @CRLF & _
",asd@example.com.,@asd.com" & @CRLF & _
"asd+spam@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")