using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\.-]+@[\w\.-]+\.\w+";
string input = @"asd@domain.com
asd@domain
asd.asd@domain.com
asd@my-domain.com
asd@domain-my.co.uk
asd@domain.co.uk
asd@domain.co.uk.gov.mil.
asd@example.local-local email
,asd@example.com.,@asd.com
asd+spam@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}