// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w\.-]+@[\w\.-]+\.\w+").unwrap();
let string = "asd@domain.com
asd@domain
asd.asd@domain.com
asd@my-domain.com
asd@domain-my.co.uk
asd@domain.co.uk
asd@domain.co.uk.gov.mil.
asd@example.local-local email
,asd@example.com.,@asd.com
asd+spam@gmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}