re = /[\w\.-]+@[\w\.-]+\.\w+/m
str = 'asd@domain.com
asd@domain
asd.asd@domain.com
asd@my-domain.com
asd@domain-my.co.uk
asd@domain.co.uk
asd@domain.co.uk.gov.mil.
asd@example.local-local email
,asd@example.com.,@asd.com
asd+spam@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end