import re
regex = re.compile(r"\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\d(\d?)(:\d\d)?(p|a)m", flags=re.MULTILINE)
test_str = ("1:00, 1pm, 1:00pm, noon, 11:30am, 1130am\n"
"1pm wednesday\n"
"wednesday\n"
"tomorrow at noon\n"
"today at 11\n"
"hot dog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")