// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\d(\d?)(:\d\d)?(p|a)m").unwrap();
let string = "1:00, 1pm, 1:00pm, noon, 11:30am, 1130am
1pm wednesday
wednesday
tomorrow at noon
today at 11
hot dog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}