package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(租赁)?.{0,9}确认(为)?使用权资产`)
var str = `租赁期开始日,本公司对租赁确认使用权资产和租赁负债
租赁期开始日,对租赁确认使用权资产和租赁负债
本公司对租赁确认使用权资产和租赁负债。
本集团在租赁期开始日对租赁确认使用权资产和租赁负债
公司对租赁确认使用权资产和租赁负债
本公司对租赁确认使用权资产和租赁负债
本公司对租赁确认使用权资产和租赁负债
在租赁期开始日,本公司对租赁确认使用权资产和租赁负债
在租赁期开始日,公司对租赁确认使用权资产和租赁负债。
在租赁期开始日,公司对租赁确认使用权资产和租赁负债
本公司选择确认使用权资产和租赁负债,
本公司对租赁确认使用权资产和租赁负债。
对租赁确认使用权资产和租赁负债
本公司对租赁确认使用权资产和租赁负债。
确认使用权资产和租赁负债
本集团对租赁确认使用权资产和租赁负债
确认为使用权资产,确认为租赁负债
本公司对租赁确认使用权资产和租赁负债
在租赁期开始日,公司对租赁确认使用权资产和租赁负债
公司租入资产所支付的租赁费,在不扣除免租期的整个租赁期内,按直线法进行分摊,计入当期费用
在租赁期开始日,公司对租赁确认使用权资产和租赁负债
在租赁期开始日,公司对租赁确 认使用权资产和租赁负债
在租赁期开始日,本公司对租赁确认使用权资产,确认租赁负债。
在租赁期开始日,公司对租赁确认使用权资产和租赁负债
本集团在租赁期开始日对租赁确认使用权资产,租赁负债
在租赁期开始日,公司对租赁确认使用权资产和租赁负债。
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}