import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(租赁)?.{0,9}确认(为)?使用权资产";
final String string = "租赁期开始日,本公司对租赁确认使用权资产和租赁负债\n"
+ "租赁期开始日,对租赁确认使用权资产和租赁负债\n"
+ "本公司对租赁确认使用权资产和租赁负债。\n"
+ "本集团在租赁期开始日对租赁确认使用权资产和租赁负债\n"
+ "公司对租赁确认使用权资产和租赁负债\n"
+ "本公司对租赁确认使用权资产和租赁负债\n"
+ "本公司对租赁确认使用权资产和租赁负债\n"
+ "在租赁期开始日,本公司对租赁确认使用权资产和租赁负债\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债。\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
+ "本公司选择确认使用权资产和租赁负债,\n"
+ "本公司对租赁确认使用权资产和租赁负债。\n"
+ "对租赁确认使用权资产和租赁负债\n"
+ "本公司对租赁确认使用权资产和租赁负债。\n"
+ "确认使用权资产和租赁负债\n"
+ "本集团对租赁确认使用权资产和租赁负债\n"
+ "确认为使用权资产,确认为租赁负债\n"
+ "本公司对租赁确认使用权资产和租赁负债\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
+ "公司租入资产所支付的租赁费,在不扣除免租期的整个租赁期内,按直线法进行分摊,计入当期费用\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
+ "在租赁期开始日,公司对租赁确 认使用权资产和租赁负债\n"
+ "在租赁期开始日,本公司对租赁确认使用权资产,确认租赁负债。\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
+ "本集团在租赁期开始日对租赁确认使用权资产,租赁负债\n"
+ "在租赁期开始日,公司对租赁确认使用权资产和租赁负债。\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}