using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|\s+)\d+\s*)m(?!\S)";
string substitution = @"$1meter";
string input = @"15M -> M
15m -> m
15 M -> M
15 m -> m
15 M and other words -> M
15 m and the word from -> should match 'm' character after ""15"" but not 'm' in ""from""
15 M and other words with 15 meter and 9m is 999mtest
or test200m ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}