import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^|\\s+)\\d+\\s*)m(?!\\S)";
final String string = "15M -> M\n"
+ "15m -> m\n"
+ "15 M -> M\n"
+ "15 m -> m\n"
+ "15 M and other words -> M\n"
+ "15 m and the word from -> should match 'm' character after \"15\" but not 'm' in \"from\"\n\n"
+ "15 M and other words with 15 meter and 9m is 999mtest\n\n"
+ "or test200m ";
final String subst = "$1meter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}