$re = '/((?:^|\s+)\d+\s*)m(?!\S)/m';
$str = '15M -> M
15m -> m
15 M -> M
15 m -> m
15 M and other words -> M
15 m and the word from -> should match \'m\' character after "15" but not \'m\' in "from"
15 M and other words with 15 meter and 9m is 999mtest
or test200m ';
$subst = "$1meter";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;