use strict;
my $str = '15M -> M
15m -> m
15 M -> M
15 m -> m
15 M and other words -> M
15 m and the word from -> should match \'m\' character after "15" but not \'m\' in "from"
15 M and other words with 15 meter and 9m is 999mtest
or test200m ';
my $regex = qr/((?:^|\s+)\d+\s*)m(?!\S)/mp;
my $subst = '$1meter';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";