#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)if [^{]+?(?={)"
Local $sString = "if (bla === 3) {" & @CRLF & _
"}" & @CRLF & _
"if ((((ol === 1 || (true))))) {}" & @CRLF & _
"if ((1 === 4)" & @CRLF & _
"(this === 9)) {}" & @CRLF & _
"some code; if (true) {} else if (false) {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")