re = /if [^{]+?(?={)/m
str = 'if (bla === 3) {
}
if ((((ol === 1 || (true))))) {}
if ((1 === 4)
(this === 9)) {}
some code; if (true) {} else if (false) {}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end