import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "if [^\\{]+?(?=\\{)";
final String string = "if (bla === 3) {\n"
+ "}\n"
+ "if ((((ol === 1 || (true))))) {}\n"
+ "if ((1 === 4)\n"
+ "(this === 9)) {}\n"
+ "some code; if (true) {} else if (false) {}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}