package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\d.]+`)
var str = `3*2.2
6+3.1*3.21
(1+2)*3
1+(1.22+3)
0.1+1+2.2423+2.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}