const regex = /[^\d.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d.]+', 'gm')
const str = `3*2.2
6+3.1*3.21
(1+2)*3
1+(1.22+3)
0.1+1+2.2423+2.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}