// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\d.]+").unwrap();
let string = "3*2.2
6+3.1*3.21
(1+2)*3
1+(1.22+3)
0.1+1+2.2423+2.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}