import re
regex = re.compile(r"[^\d.]+", flags=re.MULTILINE)
test_str = ("3*2.2\n"
"6+3.1*3.21\n"
"(1+2)*3\n"
"1+(1.22+3)\n"
"0.1+1+2.2423+2.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")