#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?=.*[A-Z])(?=.*[a-z]).{3,16})(?:[\d]*)$"
Local $sString = "faYi" & @CRLF & _
"FAiy" & @CRLF & _
"FAiy999" & @CRLF & _
"F a i yaz ahmed" & @CRLF & _
"FAiyaz SArkar" & @CRLF & _
"f a i Y z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")