$re = '/^((?=.*[A-Z])(?=.*[a-z]).{3,16})(?:[\d]*)$/m';
$str = 'faYi
FAiy
FAiy999
F a i yaz ahmed
FAiyaz SArkar
f a i Y z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);