use strict;
my $str = 'faYi
FAiy
FAiy999
F a i yaz ahmed
FAiyaz SArkar
f a i Y z';
my $regex = qr/^((?=.*[A-Z])(?=.*[a-z]).{3,16})(?:[\d]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}