re = /^((?=.*[A-Z])(?=.*[a-z]).{3,16})(?:[\d]*)$/m
str = 'faYi
FAiy
FAiy999
F a i yaz ahmed
FAiyaz SArkar
f a i Y z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end