import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])(?:(?=(\\\\?))\\2.)*?\\1(*SKIP)(*F)|(\\[([a-zA-Z]*)\\])";
final String string = "$output = \"<input name='variable[key]' has to be preserved as it is.\";\n"
+ "$output = 'Even this string variable[key] has to be preserved as it is.';\n\n"
+ "$variable[key] = \"WhatElse\";\n"
+ "$result = $wso->RSLA(\"7050\", $vegalot, \"600\", \"WFID_OK_WEB\",\"1300\", $_POST[username]);\n"
+ "if ($result[ECD] != 0) {\n"
+ "if ($line==\"AAAA\" && in_array(substr($wso->lot,0,7),$lot_aaaa_list) && $lot[wafer][25]) {";
final String subst = "['$2']";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}