$re = '/(["\'])(?:(?=(\\\\?))\2.)*?\1(*SKIP)(*F)|(\[([a-zA-Z]*)\])/';
$str = '$output = "<input name=\'variable[key]\' has to be preserved as it is.";
$output = \'Even this string variable[key] has to be preserved as it is.\';
$variable[key] = "WhatElse";
$result = $wso->RSLA("7050", $vegalot, "600", "WFID_OK_WEB","1300", $_POST[username]);
if ($result[ECD] != 0) {
if ($line=="AAAA" && in_array(substr($wso->lot,0,7),$lot_aaaa_list) && $lot[wafer][25]) {';
$subst = "['$2']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;