use strict;
my $str = '$output = "<input name=\'variable[key]\' has to be preserved as it is.";
$output = \'Even this string variable[key] has to be preserved as it is.\';
$variable[key] = "WhatElse";
$result = $wso->RSLA("7050", $vegalot, "600", "WFID_OK_WEB","1300", $_POST[username]);
if ($result[ECD] != 0) {
if ($line=="AAAA" && in_array(substr($wso->lot,0,7),$lot_aaaa_list) && $lot[wafer][25]) {';
my $regex = qr/(["'])(?:(?=(\\?))\2.)*?\1(*SKIP)(*F)|(\[([a-zA-Z]*)\])/p;
my $subst = '[\'$2\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";