import re
regex = re.compile(r"([\"'])(?:(?=(\\?))\2.)*?\1(*SKIP)(*F)|(\[([a-zA-Z]*)\])")
test_str = ("$output = \"<input name='variable[key]' has to be preserved as it is.\";\n"
"$output = 'Even this string variable[key] has to be preserved as it is.';\n\n"
"$variable[key] = \"WhatElse\";\n"
"$result = $wso->RSLA(\"7050\", $vegalot, \"600\", \"WFID_OK_WEB\",\"1300\", $_POST[username]);\n"
"if ($result[ECD] != 0) {\n"
"if ($line==\"AAAA\" && in_array(substr($wso->lot,0,7),$lot_aaaa_list) && $lot[wafer][25]) {")
subst = "['$2']"
result = regex.sub(subst, test_str)
if result:
print(result)