import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[AZQ]\\d{10,14}(>\\S+).*?(First Time : \\d\\d:\\d\\d[AP]M)";
final String string = "qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
+ "]*,qgvv]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
+ "['~£,'}'<',!']'',',<€~Z1234566789>Z12345667890\n"
+ "1'fncnr'qmtjcsmsj194&($.!:!\n"
+ ",$/&15?'?'(''(('(''158,$3,!!1\n"
+ "1'('(',';?1!( First Time : 10:10PM\n"
+ "1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
+ "AAABBB : ,$2$$(&158((&&,&,&;&(&&((&\n\n"
+ "qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
+ "]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
+ "['~£,'}'<',!']'',',<€~A1234566789>A1234566789123\n"
+ "1'fncnr'qmtjcsmsj194&($.!:!\n"
+ ",$/&15?'?'(''(('(''158,$3,!!1\n"
+ "1'('(',';?1!( First Time : 10:10PM\n"
+ "1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
+ "AAABBB : :&;&;&(&;'1(&?&,&,&1&(&(,\n"
+ "$2$$(&158((&&,&,&;&(&&((&;&;&;&;&\n\n\n"
+ "qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
+ "]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
+ "['~£,'}'<',!']'',',cjejfnfn<€~Q1234566789>Q123456678912\n"
+ "1'fncnr'qmtjcsmsj194&($.!:!\n"
+ ",$/&15?'?'(''(('(''158,$3,!!1\n"
+ "1'('(',';?1!( First Time : 10:10PM\n"
+ "1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
+ "dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}