use strict;
my $str = 'qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,qgvv]*?£[£?£,£~\'_!~£[££<£<\'<\'?£]!<!<
[\'~£,\'}\'<\',!\']\'\',\',<€~Z1234566789>Z12345667890
1\'fncnr\'qmtjcsmsj194&($.!:!
,$/&15?\'?\'(\'\'((\'(\'\'158,$3,!!1
1\'(\'(\',\';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1\'fkfkckcqtngcnnq
AAABBB : ,$2$$(&158((&&,&,&;&(&&((&
qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,€]*?£[£?£,£~\'_!~£[££<£<\'<\'?£]!<!<
[\'~£,\'}\'<\',!\']\'\',\',<€~A1234566789>A1234566789123
1\'fncnr\'qmtjcsmsj194&($.!:!
,$/&15?\'?\'(\'\'((\'(\'\'158,$3,!!1
1\'(\'(\',\';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1\'fkfkckcqtngcnnq
AAABBB : :&;&;&(&;\'1(&?&,&,&1&(&(,
$2$$(&158((&&,&,&;&(&&((&;&;&;&;&
qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,€]*?£[£?£,£~\'_!~£[££<£<\'<\'?£]!<!<
[\'~£,\'}\'<\',!\']\'\',\',cjejfnfn<€~Q1234566789>Q123456678912
1\'fncnr\'qmtjcsmsj194&($.!:!
,$/&15?\'?\'(\'\'((\'(\'\'158,$3,!!1
1\'(\'(\',\';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1\'fkfkckcqtngcnnq
dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&';
my $regex = qr/\b[AZQ]\d{10,14}(>\S+).*?(First Time : \d\d:\d\d[AP]M)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}