# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[AZQ]\d{10,14}(>\S+).*?(First Time : \d\d:\d\d[AP]M)"
test_str = ("qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,qgvv]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',<€~Z1234566789>Z12345667890\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"AAABBB : ,$2$$(&158((&&,&,&;&(&&((&\n\n"
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',<€~A1234566789>A1234566789123\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"AAABBB : :&;&;&(&;'1(&?&,&,&1&(&(,\n"
"$2$$(&158((&&,&,&;&(&&((&;&;&;&;&\n\n\n"
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',cjejfnfn<€~Q1234566789>Q123456678912\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.