#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|[^\\\n])\\(?:\\{2})*(??\b)\d+(?:\.\d*)?"
Local $sString = "\5" & @CRLF & _
"\\5" & @CRLF & _
"\\\5" & @CRLF & _
"\\\4" & @CRLF & _
"\4." & @CRLF & _
"\44" & @CRLF & _
"\4456" & @CRLF & _
"\\\6" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")