// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^|[^\\\n])\\(?:\\{2})*(??\b)\d+(?:\.\d*)?").unwrap();
let string = "\\5
\\\\5
\\\\\\5
\\\\\\4
\\4.
\\44
\\4456
\\\\\\6
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}