re = /(?:^|[^\\\n])\\(?:\\{2})*(??\b)\d+(?:\.\d*)?/m
str = '\\5
\\\\5
\\\\\\5
\\\\\\4
\\4.
\\44
\\4456
\\\\\\6
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end