#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+):(.+(?:\n .*|\n[^:\n]+$)*)"
Local $sString = "Key: in-line value" & @CRLF & _
"Key2: in-line value: with a colon" & @CRLF & _
"Key3: multi-line value" & @CRLF & _
"which continues here" & @CRLF & _
"Key4: multi-line value which" & @CRLF & _
" continues here: has a colon" & @CRLF & _
" yet is still a value"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")