import re
regex = re.compile(r"^(\w+):(.+(?:\n .*|\n[^:\n]+$)*)", flags=re.MULTILINE)
test_str = ("Key: in-line value\n"
"Key2: in-line value: with a colon\n"
"Key3: multi-line value\n"
"which continues here\n"
"Key4: multi-line value which\n"
" continues here: has a colon\n"
" yet is still a value")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")