re = /^(\w+):(.+(?:\n .*|\n[^:\n]+$)*)/m
str = 'Key: in-line value
Key2: in-line value: with a colon
Key3: multi-line value
which continues here
Key4: multi-line value which
continues here: has a colon
yet is still a value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end