package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+):(.+(?:\n .*|\n[^:\n]+$)*)`)
var str = `Key: in-line value
Key2: in-line value: with a colon
Key3: multi-line value
which continues here
Key4: multi-line value which
continues here: has a colon
yet is still a value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}