# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?:\.\d+)?(?:(?:x\d+(?:\.\d+)?)*)?(?=[ \t]+[cm]m)/\1 [[replacement]]/gm;t' <<< "The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.
The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively."