re = /\d+(?:\.\d+)?(?:(?:x\d+(?:\.\d+)?)*)?(?=[ \t]+[cm]m)/m
str = 'The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.
The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.'
subst = '\\1 [[replacement]]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result