const regex = new RegExp('\\d+(?:\\.\\d+)?(?:(?:x\\d+(?:\\.\\d+)?)*)?(?=[ \\t]+[cm]m)', 'gm')
const str = `The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.
The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size
Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.`;
const subst = `\1 [[replacement]]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);