import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)?(?:(?:x\\d+(?:\\.\\d+)?)*)?(?=[ \\t]+[cm]m)";
final String string = "The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size\n"
+ "Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.\n\n"
+ "The study reveals a speculated nodule with pleural tagging at anterior basal segment of LLL, measured 1.9x1.4x2.0 cm in size\n"
+ "Other two ill defined, small ground glass lesions measured 4.0 mm and 3 mm in size, respectively.";
final String subst = "\\1 [[replacement]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}