import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\w*\\W){12}(\\w)(\\D).{4}(.)\\S\\s(.)(\\D))\n"
+ "[^a]+(.)(?=.*?(?![^p])(.)\\w*(\\w))[^i]*([^\\W]\n"
+ ")\\s+..\\s[rf]+([^0-9]).\\b..?(\\D)\\w*\\W(\\w).(.)\n"
+ "([\\S\\s])[^.]+(\\W)[\\S\\s]*\\|(?=\\s(\\S))[\\s\\S]++";
final String string = "We did not inherit this earth from our parents, we have borrowed it from our children.\n\n"
+ " /-\n"
+ " .-|=====-.\n"
+ " | @ |\n"
+ " ___|________|\n"
+ " ||\n"
+ " <_> \\ || \\|/ \\_/\n"
+ " \\|/ \\\\|| \\\\| |//\n"
+ " __\\|//_\\\\|///_\\V/_\\|//__\n";
final String subst = "$1$2$1$1${14}$3${15}$1${11}$1$1${14}$3${16}$3${12}${14}${13}$7${8}$2${15}$6$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}