re = /^(?=(?:\w*\W){12}(\w)(\D).{4}(.)\S\s(.)(\D))
[^a]+(.)(?=.*?(?![^p])(.)\w*(\w))[^i]*([^\W]
)\s+..\s[rf]+([^0-9]).\b..?(\D)\w*\W(\w).(.)
([\S\s])[^.]+(\W)[\S\s]*\|(?=\s(\S))[\s\S]++/mx
str = 'We did not inherit this earth from our parents, we have borrowed it from our children.
/-
.-|=====-.
| @ |
___|________|
||
<_> \\ || \\|/ \\_/
\\|/ \\\\|| \\\\| |//
__\\|//_\\\\|///_\\V/_\\|//__
'
subst = '$1$2$1$1${14}$3${15}$1${11}$1$1${14}$3${16}$3${12}${14}${13}$7${8}$2${15}$6$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result