# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?=(?:\w*\W){12}(\w)(\D).{4}(.)\S\s(.)(\D))
[^a]+(.)(?=.*?(?![^p])(.)\w*(\w))[^i]*([^\W]
)\s+..\s[rf]+([^0-9]).\b..?(\D)\w*\W(\w).(.)
([\S\s])[^.]+(\W)[\S\s]*\|(?=\s(\S))[\s\S]++
"""
test_str = ("We did not inherit this earth from our parents, we have borrowed it from our children.\n\n"
" /-\n"
" .-|=====-.\n"
" | @ |\n"
" ___|________|\n"
" ||\n"
" <_> \\ || \\|/ \\_/\n"
" \\|/ \\\\|| \\\\| |//\n"
" __\\|//_\\\\|///_\\V/_\\|//__\n")
subst = "$1$2$1$1${14}$3${15}$1${11}$1$1${14}$3${16}$3${12}${14}${13}$7${8}$2${15}$6$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.