#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[^,]*,(?!\d{9}(?:[xv]|\d{3}))[^,]+,"
Local $sString = "foo,666666666v,bar" & @CRLF & _
"foo,123456789012,bar" & @CRLF & _
",nope,bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")