import re
regex = re.compile(r"^[^,]*,(?!\d{9}(?:[xv]|\d{3}))[^,]+,", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("foo,666666666v,bar\n"
"foo,123456789012,bar\n"
",nope,bar")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")